Site slowness issues are resolved now.
Downstream infrastructure issues like this prevent us from being able to scale up the number of servers running to serve our traffic. Going forward we will be increasing the base number of servers always running to prevent infrastructure issues like this.
Sorry for the inconvenience and thank you for your patience.
Resolved
Site slowness issues are resolved now.
Downstream infrastructure issues like this prevent us from being able to scale up the number of servers running to serve our traffic. Going forward we will be increasing the base number of servers always running to prevent infrastructure issues like this.
Sorry for the inconvenience and thank you for your patience.
Investigating
Our infrastructure provider (Heroku) appears to be recovering and we've been able to increase our provisioned infrastructure. Our site should be recovering as well
Investigating
We are investigating an issue where the PIMs and HD clinic portals are seeing excessive slowness. This is due to an issue with our infrastructure provider. We will provide updates as we have them